Phoca Download

FAQ for Phoca Download

Have a question not answered here? Contact our Support Team!


Joomla Compatibility: Phoca Download is available for Joomla! 1.5.x, Joomla! 2.5.x and Joomla! 3.0.x

Joomla Components Required: Phoca Download

Browser Requirements: The minimum recommended browser versions are IE8, Safari

 

1 Setting Up Front End Upload Users (Hot!)
2 Phoca File upload (Hot!)

All logos, trademarks, and product names are property of their respective owners. Their listing above does not represent an endoresement of or affiliation with interGen, inc.